Bank Millenium Open Banking Major Outage
Incident Report for Tink providers Poland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Nov 08, 2023 - 09:10 UTC
Investigating
We are currently investigating an issue with Bank Millenium Open Banking.
Posted Oct 27, 2023 - 13:22 UTC
This incident affected: Bank Millennium.