Bank Millennium Open Banking - Full service outage

Incident Report for Tink providers Poland

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 09:08 CET

Investigating

We are currently investigating an issue with Bank Millennium.

- Affected users: 100%
- Affected flow: Manual authentication and Payments
- Start Time: 30/10/2025 15:30 CET
- Error: bank side
- Provider name: pl-millennium-ob
Posted Oct 30, 2025 - 16:39 CET
This incident affected: Bank Millennium.