Bank Millennium - Major outage

Incident Report for Tink providers Poland

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Nov 03, 2025 - 10:12 CET

Investigating

We are currently investigating an issue with Bank Millennium.

- Affected users: 100%
- Affected flow: Manual authentication, Payments
- Start Time: 31/10/2025 12:10 CET
- Provider name: pl-millennium-ob
Posted Oct 31, 2025 - 12:37 CET
This incident affected: Bank Millennium.