Bank Millennium - Major Outage

Incident Report for Tink providers Poland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Sep 25, 2026 - 09:25 CEST

Investigating

We are currently investigating an issue with Bank Millennium.

- Affected users: 90%
- Affected flow: AIS
- Start Time: 24.09.2026 09:15 CEST
- Provider name: pl-millenium-ob
Posted Sep 24, 2026 - 10:07 CEST
This incident affected: Bank Millennium.